A8 Parts Forum  

Go Back   A8 Parts Forum > A8 D2 > D2 - Engine Bay

D2 - Engine Bay Everything under the bonnet

Reply
 
Thread Tools Display Modes
  #1  
Old 12th August 2019, 04:15 PM
Audi Doody Audi Doody is offline
Junior Member
 
Join Date: May 2019
Posts: 25
Default Audi A8 2.8 running issue

Hi all,

Have had my A8 since May, and in that time have covered 2340 trouble free miles.
That ended today however: the car started well enough and I drove it a couple of miles. I went to pull away from some traffic lights, and the engine stalled. So I put it in neutral, restarted it and it crept, but was unresponsive to throttle inputs. I pulled up to the side of the road and turned the engine off and restarted it. The EML, ABS and EPC lights were on. Also idel was erratic, jumping between 800 and 1200 rpm. The throttle would let the engine gently rev to 2k, but not past - this was only in neutral, in gear it was idle only.
Anyway, I managed to limp home at 10 mph using creep, I had to stop a few times, and when putting in D, it would do so with a bang.
Pulled in my drive, turned it off, turned it on again, and all the dash lights were out, and idled and revved fine! Took for a very quick test drive and it was faultless - moved in to D smoothly.

I know it needs diagnosing; but is anyone familiar with this? Very annoyed as I was planning on going to Europe this week; am happy that it decided to happen now though..
Reply With Quote
  #2  
Old 12th August 2019, 06:34 PM
johnny_quattro's Avatar
johnny_quattro johnny_quattro is offline
Senior Member
 
Join Date: Sep 2012
Location: London
Posts: 395
Default

I would check for possible water ingress into the electronics box area (as I call it) under the bonnet. It's up on the right-hand passenger's side next to the firewall and has an easily-removable cover. This may be different on a 2.8 to the 4.2 though that I have. On my car, the ABS box was I think the lowest one, and then my gearbox TCU sits above it. Bearing in mind the recent rainy weather, I suspect that this area might be full of water. It's certainly worth checking.
__________________
2000 D2 A8L Audi silver, solar sunroof, heated front Recaros
20 FE wheels, electric rear blind/manual passenger blinds
Sony XAV 601BT double DIN stereo
VIBE M8K RMS @ 2Ω: 2800 watts
Orion 154 HCCA subwoofer Black Coil edition, no less.
Custom-built sealed box
Reply With Quote
  #3  
Old 12th August 2019, 07:24 PM
Audi Doody Audi Doody is offline
Junior Member
 
Join Date: May 2019
Posts: 25
Default

Hi, yes good shout. I did suspect the rain might have had something to do with it.
I did just look under the cover and it looks dry. I'd like to replace these seal though, just to ensure it stays watertight.
I'll have to get it plugged in.
Reply With Quote
  #4  
Old 12th August 2019, 07:49 PM
moltuae's Avatar
moltuae moltuae is offline
Senior Member
 
Join Date: Sep 2014
Location: East Lancs.
Posts: 2,452
Default

I'd also check your battery and alternator condition and check that the battery terminals are making good contact.
__________________
Mark
------------------------------------------------------
2002 FE S8 Ebony Black Pearl
------------------------------------------------------

------------------------------------------------------
Cars Owned:

The Audi Era: '97 A8 4.2 (Ming Blue) --> '96 A8 4.2 QS (Dark Green) --> '02 FE S8 (present)
The Citroen Era: '84 BX 1.6 RS --> '89 BX 1.9 DTR Turbo --> '94 XM 2.0L Turbo --> '96 XM 2.0L Turbo Exclusive --> '00 Xantia Activa 2.0L Turbo
The Banger Era: '76 1.2L Lada VAZ-2101 (Ruski Fiat 124) --> '80 1.7L Morris Ital HL, finished in Ermine White and Rust
Reply With Quote
  #5  
Old 12th August 2019, 08:08 PM
Audi Doody Audi Doody is offline
Junior Member
 
Join Date: May 2019
Posts: 25
Default

Will do. Where is the battery located on these, is it under the rear seat?
Reply With Quote
  #6  
Old 12th August 2019, 08:57 PM
moltuae's Avatar
moltuae moltuae is offline
Senior Member
 
Join Date: Sep 2014
Location: East Lancs.
Posts: 2,452
Default

Quote:
Originally Posted by Audi Doody View Post
Will do. Where is the battery located on these, is it under the rear seat?
In the boot, right hand side recess. Should be a cover that just lifts off to reveal the battery. It's quite a tight fit so it's a bit of a faff to get the battery in and out.

Found a photo of the compartment: https://i.imgur.com/ghwxtx5.jpg
__________________
Mark
------------------------------------------------------
2002 FE S8 Ebony Black Pearl
------------------------------------------------------

------------------------------------------------------
Cars Owned:

The Audi Era: '97 A8 4.2 (Ming Blue) --> '96 A8 4.2 QS (Dark Green) --> '02 FE S8 (present)
The Citroen Era: '84 BX 1.6 RS --> '89 BX 1.9 DTR Turbo --> '94 XM 2.0L Turbo --> '96 XM 2.0L Turbo Exclusive --> '00 Xantia Activa 2.0L Turbo
The Banger Era: '76 1.2L Lada VAZ-2101 (Ruski Fiat 124) --> '80 1.7L Morris Ital HL, finished in Ermine White and Rust

Last edited by moltuae; 12th August 2019 at 08:59 PM.
Reply With Quote
  #7  
Old 12th August 2019, 09:22 PM
Audi Doody Audi Doody is offline
Junior Member
 
Join Date: May 2019
Posts: 25
Default

Lovely, thanks!!
Reply With Quote
  #8  
Old 19th August 2019, 04:29 PM
Audi Doody Audi Doody is offline
Junior Member
 
Join Date: May 2019
Posts: 25
Default

So drove the car back from London to Bmth last week, everything was fine until the last 5 miles when travelling at 70mph the fault happened again. I put it in neutral turned the car off and on and it was fine - has been ever since.
Took it for diagnostics to a friend who's a VAG specialist, and several faults were logged; all to do with the throttle body, oh and a lambda sensor looked borked.
It's going back tomorrow as they noticed some corrosion on the electrical connections (but the engine bay was too hot to look in to further). So hopefully something conclusive comes back; fingers crossed it's not the throttle body as they're big bucks aren't they

Oh and the cruise control switch was flagged as broken- makes sense as cruise control doesn't work - do I just need a new stalk?
Reply With Quote
  #9  
Old 19th August 2019, 05:08 PM
steamship's Avatar
steamship steamship is offline
Senior Member
 
Join Date: Jun 2013
Location: Londonderry, Northern Ireland
Posts: 1,655
Default

Quote:
Originally Posted by Audi Doody View Post
fingers crossed it's not the throttle body as they're big bucks aren't they

Oh and the cruise control switch was flagged as broken- makes sense as cruise control doesn't work - do I just need a new stalk?
Check out the site sponsors on eBay (a8parts). They have several starting from 28 if you want to go secondhand. If you want to purchase new, give them a call on 01642 783537, as they can order them in.

They might even have the cruise control stalk.
__________________
2001 A8 D2 FL 3.7 Q - LPG Conversion, Engine: AKC, Gearbox:FBB, Colour:LY5X Aqua Blue pearl effect, Interior:WJ light beige/dark beige valcona leather with burr walnut inserts

My DIY jobs - Replaced alarm horn, Replaced Coolant Temp sensor, Updated RNS-D firmware, Installed Reversing Camera and Digital TV, Dashcam Installation, Retrofitted Rear Blinds, Auto-Dimming Rear View Mirror, Chrome Boot Struts

Sold! 2008 S8 D3 5.2 V10 - Engine: BSM, Gearbox:KLW, Colour:LY7F Suzuka Grey Pearl Effect, Interior:Black/Black with Silver/Black valcona leather with carbon atlas inserts, Bang & Olufsen, Heated windscreen, Soft-close doors, TV, DAB, AMI, Quad Zone, Auto Boot, Auto dim Mirrors, Keyless entry, PDC with rearview camera, AFS II Headlights

My DIY jobs - Fan Jet Windscreen Washers, Retrofitted Electric Side Blinds
Reply With Quote
  #10  
Old 19th August 2019, 05:14 PM
HPsauce HPsauce is offline
Senior Member
 
Join Date: Sep 2011
Location: About 250m from HS2!
Posts: 6,942
Default

Cruise control has two fundamentally different versions, which depends on the age of your car. As I think is flagged prominently on the forum, it helps if you supply more details of your car as answers do depend on precise vintage, trims, etc.
__________________
2003 D2 FL S8. Irish Green Pearl/Beige. Solar sunroof, auto-dim mirrors, electric rear seat functions, ski hatch retrofit; extended leather. Aftermarket DVB-T, reversing camera and full XCarlink (Bluetooth etc.).
2016 Volvo V40 T5 Cross Country (4WD) with ALL the toys including adaptive cruise etc. etc. Osmium Grey with Blonde/Charcoal leather interior. Polestar performance "optimisation". (A much rarer model than a D2 S8 by the way!)
Finally: gone, but not forgotten.....
1998 D2 PF S8. AgateGrey/Platinum. Every option (I think) except electric rear seats, tiptronic steering wheel, ski hatch, towbar & dimming door mirrors.
e.g. Cruise control, NavPlus/TV, Bose, GSM, Xenons, Solar roof, Parking sensors, Alcantara/leather everywhere of course. (internal dimming mirror added later)
1998 (very early) Ford Focus 1.8 Zetec; ABS/TCS, Heated screen/mirrors, Aircon, Auto-dim mirror, Leather, Trip computer, Cruise control, OEM Ford SatNav with CD changer.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:49 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.