A8 Parts Forum  

Go Back   A8 Parts Forum > A8 D3 > D3 - Interior Electrics

D3 - Interior Electrics Airbags, Sensors, climate modules, instrument clusters, switches etc

Reply
 
Thread Tools Display Modes
  #31  
Old 27th October 2017, 06:49 PM
neeldub neeldub is offline
Senior Member
 
Join Date: Oct 2015
Location: London
Posts: 117
Default

Hi i need some help from owners with side assist fitted.

I've been trying to retrofit this system but I am stuck with an error code caused by the driver side side assist light.

02854 - Warning Lamp for Lane Change Assistance (in right exterior mirror) (K234)
010 - Open or Short to Plus
Freeze Frame:
Fault Status: 01101010
Fault Priority: 3
Fault Frequency: 1
Reset counter: 227

For some reason, that light is always lit up even when the iginition is off.

I tested using my multimeter which shows that there is a constant 12v being supplied to the right light and not the left side. Now is this normal?

Many thanks
__________________

2010 Audi A8 4E Quattro Sport TDI Oyster Grey
Reply With Quote
  #32  
Old 27th October 2017, 08:15 PM
Delboy's Avatar
Delboy Delboy is offline
Senior Member
 
Join Date: Aug 2013
Location: Lowestoft, Suffolk
Posts: 2,462
Default

I'd say no and your error is telling you the same.

You need to check the wiring is correct and free from problems from module to the light
__________________
Del

Reply With Quote
  #33  
Old 29th October 2017, 12:46 AM
neeldub neeldub is offline
Senior Member
 
Join Date: Oct 2015
Location: London
Posts: 117
Default

I reckon it might be the Master module itself causing the problem.. as for the wiring i've checked several times and everything seems in order. I even swapped the mirror lights with each other to check for issues and the driver side still remains lit up.

I'm trying to source another Master module 4L0910566C on ebay but most are over 100... hmmmmm
__________________

2010 Audi A8 4E Quattro Sport TDI Oyster Grey
Reply With Quote
  #34  
Old 26th March 2018, 12:22 AM
neeldub neeldub is offline
Senior Member
 
Join Date: Oct 2015
Location: London
Posts: 117
Default

Finally I have been able to resolve the error codes!!!!

The issue was the custom wiring harness i made for the bumper.. I'm guessing there was a split wire somewhere which caused a grounding issue for the driver side mirror lamp.

Just need to take the car for a drive now hoping that the system will calibrate itself, if not it will be a trip to the dealers for it. Won't be cheap though as they want a full 1.5hr of labour for the task!
__________________

2010 Audi A8 4E Quattro Sport TDI Oyster Grey
Reply With Quote
  #35  
Old 15th April 2018, 01:01 AM
neeldub neeldub is offline
Senior Member
 
Join Date: Oct 2015
Location: London
Posts: 117
Default

So here's another issue..

Side assist is drawing too much current while the car is 'sleeping' and ignition/ignition off. I connected my multimeter to the fuse i retrofitted (In the left fuse box), fuse 36, and it's showing me that there is a current draw of 331 milliamps which i'm guessing is causing my battery to drain significantly. There are no error codes stored on the side assist modules which would indicate a power issue with the units. My understanding is that CANBUS should put the modules to sleep when everything is completely off but that's not what's happening in my case.

Any help or advice would be appreciated.

Many thanks
__________________

2010 Audi A8 4E Quattro Sport TDI Oyster Grey
Reply With Quote
  #36  
Old 8th October 2018, 08:36 PM
homer simpson's Avatar
homer simpson homer simpson is offline
Senior Member
 
Join Date: Nov 2013
Posts: 423
Default

Hi neeldub, did you ever get this fully working? Was it worth it?
__________________
2008 (facelift) S8 with B&O, ACC, glass sunroof, reversing camera, front and rear heated seats, ceramic brakes, homelink, electric side and rear blinds, ski load through, heated fan washer jets
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:17 PM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.