A8 Parts Forum  

Go Back   A8 Parts Forum > A8 D4 > D4 - Axles, Brakes, Suspension and Steering

D4 - Axles, Brakes, Suspension and Steering Brakes, Springs, shocks, steering racks, steering columns, suspension arms, wheel hubs etc.

Reply
 
Thread Tools Display Modes
  #1  
Old 21st March 2024, 12:03 AM
manca manca is offline
Senior Member
 
Join Date: May 2012
Location: Nr Kingston, Surrey
Posts: 226
Default Brake Servo Replacement 4.2tdi

Hi folks
Anyone had this done. I've got an issue where the brake boost isn't working following engine start up. First noticed it in a car park, and yesterday on the driveway. As soon as I'm off and moving everything is fine. Local indie had car today and says vacuum draw and pressure seem okay although they dont have data for a 2010 engine so basing it off other cars.... but the servo is slow to react and they suggest as point one needs replacing. Quoting 1500 as a starting point saying upper limit unknown as multiple parts including both calipers may need replacing following brake bleeding and strip down as they are prone to damage.
__________________
2010 D4 4.2tdi. phantom Black Pearl Effect. Night vision assistance with pedestrian detection. Parking aid plus. Audi pre-sense plus. Adaptive cruise control. Audi side assist. Bluetooth privacy handset. Mobile telephone preparation - High with Audi connect. CD/DVD changer. Bose surround-sound system. Through load facility. Homelink garage door opener. Advanced Key. Deluxe 4 zone climate control with rear comfort centre armrest. Adaptive Headlight with high beam assist. Electric sun blinds for rear window and rear door windows. Heated outer rear seats. Comfort seats with memory function. Extended leather pack 1. 21 inch Rotor alloys.
Reply With Quote
  #2  
Old 21st March 2024, 05:39 AM
ainarssems ainarssems is offline
Senior Member
 
Join Date: Aug 2010
Location: Rushden, Northants
Posts: 3,800
Default

Sorry, no experience changing it on D4 but seems a bit suspicious that it works when you start moving. I would think it's not enough vacuum in idle and when you start moving and rpm increase you have more vacuum and it works, which would mean weak pump or vacuum leak somewhere, of course could be a leak inside servo too. Should do a vacuum leak test on whole system and individual parts first before committing to replace servo.
__________________
Currently 8less
2011 Q7 S Line 3.0TDI, 2016 Tesla Model S 90D

8 history:
2006 A8 Sport 4.2TDI quattro SOLD,
1997 S8, reached end of life with gearbox failure
Reply With Quote
  #3  
Old 21st March 2024, 11:17 AM
manca manca is offline
Senior Member
 
Join Date: May 2012
Location: Nr Kingston, Surrey
Posts: 226
Default

Thanks for replying ainarssems.

That gives me a bit of hope. I'm off to collect the car later today so I'll ask some questions
__________________
2010 D4 4.2tdi. phantom Black Pearl Effect. Night vision assistance with pedestrian detection. Parking aid plus. Audi pre-sense plus. Adaptive cruise control. Audi side assist. Bluetooth privacy handset. Mobile telephone preparation - High with Audi connect. CD/DVD changer. Bose surround-sound system. Through load facility. Homelink garage door opener. Advanced Key. Deluxe 4 zone climate control with rear comfort centre armrest. Adaptive Headlight with high beam assist. Electric sun blinds for rear window and rear door windows. Heated outer rear seats. Comfort seats with memory function. Extended leather pack 1. 21 inch Rotor alloys.
Reply With Quote
  #4  
Old 21st March 2024, 04:49 PM
manca manca is offline
Senior Member
 
Join Date: May 2012
Location: Nr Kingston, Surrey
Posts: 226
Default

Picked the car up this afternoon, the Master Tech who worked on my car yesterday wasn't in and no one else to speak to me so left with car. Started engine put it into D rolled forwards, pressed brake, no servo. Lever into N blipped throttle to 2k rpm for a couple of seconds, repeated roll forward and servo worked. Released brake pedal and tried again, no servo. Headed gingerly down the road 10-15 mph.... servo working for one brake push but not subsequent when pumping brakes. This got better the further I went until at least 3 brake pushes kept servo assistance even if I didn't touch accelerator. Out onto main road and normal driving for about half a mile. Then in a traffic Jam for 15 mins, where almost no accelerator just roll forward a bit and brake repeatedly. Finally free of the traffic there was 2 miles of mixed driving up to and including a mile or so at 40ish mph. Throughout brakes worked with servo as I would expect. Got home parked up. Tried rolling forward and pumping brakes. First couple of presses had servo and then pedal got firmer and firmer with no servo assistance.
__________________
2010 D4 4.2tdi. phantom Black Pearl Effect. Night vision assistance with pedestrian detection. Parking aid plus. Audi pre-sense plus. Adaptive cruise control. Audi side assist. Bluetooth privacy handset. Mobile telephone preparation - High with Audi connect. CD/DVD changer. Bose surround-sound system. Through load facility. Homelink garage door opener. Advanced Key. Deluxe 4 zone climate control with rear comfort centre armrest. Adaptive Headlight with high beam assist. Electric sun blinds for rear window and rear door windows. Heated outer rear seats. Comfort seats with memory function. Extended leather pack 1. 21 inch Rotor alloys.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:37 PM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.